Rails 2.2 & Inflector & Dependencies

Si has actualizado a rails 2.2 (o superior) desde una versión previa puedes encontrarte con un par de errores típicos con una solución muy simple:

`const_missing’: uninitialized constant Rails::Plugin::Dependencies (NameError)

Es debido a que Dependencies ahora es ActiveSupport::Dependencies.

`load_missing_constant’: uninitialized constant Inflector (NameError)

Es debido a que Inflector ahora es ActiveSupport::Inflector. Por lo que ahora puedes usar las inflections tal que así:

ActiveSupport::Inflector.inflections do |inflect|  
  ...
end

Comments are closed.

Post Navigation